В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vasinmihailov
vasinmihailov
29.03.2020 09:03 •  Информатика

Написать программу в паскале. указания: заполните одномерный числовой массив а[15] случайными целыми числами в интервале [18; 15].выведите значения элементов массива сначала в столбик,а затем в строку,причем на каждый элемент отведите 4 позиции. : заменить элементы массива,которые кратны пяти,на значение максимального элемента массива.

Ответ:
TheTanyaStar2k
TheTanyaStar2k
01.10.2020 22:53
Const n=15;
var
a:array[1..n]of integer;
i,i_max:integer;
begin     
    for i:=1 to n do       
      begin             
          a[i]:=random(4)+15;           
          writeln(a[i]);         
      end;     
writeln;   
     for i:=1 to n do         
         write(a[i]:4);         
              writeln;     
     i_max:=1;     
         for i:=2 to n do         
           if a[i]>a[i_max]then           
              i_max:=i;     
         for i:=1 to n do       
             if a[i]mod 5=0 then           
                 a[i]:=a[i_max];     
        for i:=1 to n do       
           write(a[i]:4);
            end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?