В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vanya2155
Vanya2155
24.10.2022 08:36 •  Информатика

Составить программу! надо ракета запускается с земли со скоростью v(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости v. известно,что при v16,4 ракета покинет солнечную систему.

Ответ:
tigranmesropyan
tigranmesropyan
01.10.2020 22:52
Решение на VB

Sub Rocket()
    Dim x As Single
    x = InputBox("Введите скорость ракеты в км/с")
    Select Case x
    Case Is < 7.91
        MsgBox "Ракета упадет на Землю"
    Case 7.91
        MsgBox "Ракета будет вращаться вокруг Земли по круговой орбите"
    Case Is < 11.2
        MsgBox "Ракета будет вращаться вокруг Земли по эллиптической орбите"
    Case Is < 16.4
        MsgBox "Ракета будет перемещаться в пределах Солнечной системы"
    Case Else
        MsgBox "Ракета покинет Солнечную систему"
    End Select
End Sub
0,0(0 оценок)
Ответ:
Alexa2608
Alexa2608
01.10.2020 22:52
Var v:real;
begin
write('Введите скорость в км/c: ');
readln(v);
if v<7.9 then
  writeln('Ракета упадет на Землю');
if v=7.9 then
  writeln('Ракета будет двигаться вокруг Земли по круговой орбите');
if (v>7.9) and (v<11.2) then
  writeln('Ракета будет двигаться вокруг Земли по эллиптической орбите');
if v=11.2 then
  writeln('Ракета будет двигаться вокруг Солнца по круговой орбите');
if (v>11.2) and (v<16.4) then
  writeln('Ракета будет двигаться вокруг Солнца по эллиптической орбите');
if v>16.4 then writeln('Ракета покинет Солнечную систему');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?