В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Cxvdjx830u5b
Cxvdjx830u5b
20.01.2022 06:01 •  Информатика

Написать программу в паскале напишите программу, подсчитывающую количество различных букв в заданном слове. входные данные: ввести строкy y с длиной не более 255 символов. выходные данные: вывести одно число, количество различных символов в данной строке.

Ответ:
2K99
2K99
01.10.2020 22:48
var
  y, b: string;
  i: integer;

begin
  readln(y);
  for i := 1 to length(y) do
    if (Pos(y[i], b) = 0) then
      b := concat(b, y[i]);
  writeln(length(b));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?