В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nasstya05
nasstya05
21.08.2022 05:36 •  Информатика

Напишите программу, подсчитывающую количество букв во введенной строке (слове).

Ответ:
mykolivannp085fw
mykolivannp085fw
01.10.2020 22:50
Var
  s: string;
  letters: set of 'А'..'я';
  i, n: integer;

begin
  writeln('Введите текст');
  readln(s);
  n := 0;
  letters := ['А'..'я'];
  for i := 1 to length(s) do
    if s[i] in letters then n := n + 1;
  writeln('Количество букв в строке: ', n);
end.

Тестовое решение:

Введите текст
Это текст содержащий буквы, цифры (1,2,3,4), латиницу werwer sxFFSFw и зн"ачки [email protected]#$%#^
Количество букв в строке: 43
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?