В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Макслей
Макслей
21.02.2022 00:18 •  Информатика

Построить блок схему алгоритма и написать программу для решения: даны действительные числа z,y,x.если сумма двух чисел x y меньше единицы ,то каждое из заданных трёх чисел заменить полусуммой двух других,в противном случае возвести в квадрат.

Ответ:
dasha8743
dasha8743
08.07.2020 01:45
var
  x, y, z: real;
  a, b, c: real;
  
begin
  readln(x, y, z);
  if (x + y < 1) then
  begin
    a := (y + z) / 2;
    b := (x + z) / 2;
    c := (x + y) / 2;
    x := a;
    y := b;
    z := c;
  end
  else
  begin
    x := sqr(x);
    y := sqr(y);
    z := sqr(z);
  end;
  writeln(x, ' ', y, ' ', z);
end.
Построить блок схему алгоритма и написать программу для решения: даны действительные числа z,y,x.есл
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?