В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
varvara273
varvara273
30.05.2021 07:26 •  Информатика

Составте программу (паскале абц) и блок схему даны два действительных положительных числа x и y. тригонометрические действия над числами пронумерованы (1 - sin, 2 - cos, 3 - tg, 4 - ctg). составить программу, которая по введенному номеру n выполняет то или иное действие над числами x и y.

Ответ:
TRЮM
TRЮM
08.07.2020 01:44
var
  n: integer;
  x, y: real;

begin
  readln(n, x, y);
  case n of
    1: writeln('sin(', x, ') = ', sin(x), #13, 'sin(', y, ') = ', sin(y));
    2: writeln('cos(', x, ') = ', cos(x), #13, 'cos(', y, ') = ', cos(y));
    3: writeln('tg(', x, ') = ', tan(x), #13, 'tg(', y, ') = ', tan(y));
    4: writeln('ctg(', x, ') = ', 1 / tan(x), #13, 'ctg(', y, ') = ', 1 / tan(y));
    else
      writeln('Null');
  end;
end.
Составте программу (паскале абц) и блок схему даны два действительных положительных числа x и y. три
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?