В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Karina2048
Karina2048
15.08.2021 11:30 •  Информатика

Составьте программу поиска трехзначных чисел которые при делении на 43 в остатке 41 а при делении на 47 в остатке 43

Ответ:
SVINKAPIPA
SVINKAPIPA
08.07.2020 01:32
А нет таких чисел!

var
  i:integer;
begin
  for i:=1 to 10000 do  // по условиям задачи i:=1 to 999
    if (i mod 43 = 41) and (i mod 47 = 43) then
      writeln(i);
end.

Результаты вывода:
1030
3051
5072
7093
9114

Так что минимальное число, удовлетворяющее требованиям, 1030, но оно не трехзначное

Вот более продвинутый алгоритм, делающий то же самое:

var
  n43:integer;
begin
  n43:=127;
  repeat
    n43:=n43+43;
  until (n43 mod 43 = 41) and (n43 mod 47 = 43); //добавить and (n43<1000)
  writeln(n43)
end.

Результат вывода:
1030
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?