В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

2) написать программу вычисления площади треугольника, если известны длины двух сторон и величина угла между этими сторонами. ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). вычисление площади треугольника. введите (через пробел) длины двух сторон (см) треугольника = 25 17 введите величину угла между сторонами треугольника = 30 площадь треугольника: 106.25 кв.см.

Ответ:
aydin6
aydin6
01.10.2020 22:49
Var
  a,b,alpha,s:real;
begin
  writeln('Вычисление площади треугольника');
  writeln('Введите (через пробел) длины двух сторон (см) треугольника');
  readln(a,b);
  writeln('Введите величину угла (градус) между сторонами треугольника');
  readln(alpha);
  alpha:=DegToRad(alpha);
  writeln('Площадь треугольника: ',0.5*a*b*sin(alpha),' кв.см.')
end.

Тестовое решение:

Вычисление площади треугольника
Введите (через пробел) длины двух сторон (см) треугольника
25 17
Введите величину угла (градус) между сторонами треугольника
30
Площадь треугольника: 106.25 кв.см.

Вычисление площади треугольника
Введите (через пробел) длины двух сторон (см) треугольника
11 16.3
Введите величину угла (градус) между сторонами треугольника
39
Площадь треугольника: 56.4185730576179 кв.см.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?