В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dimon564557
dimon564557
08.11.2021 19:39 •  Информатика

Решить в паскале 1) составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6. 2) введено 3-значное число. вывести число в зеркальном отображении. 3)введенное 4-значное число изменить так, чтобы 1-3 и 2-4 цифры поменялись местами.

Ответ:
доброx5
доброx5
01.10.2020 22:46
Program task1;
var  a :integer;
begin
  randomize;  a:= 0;  while (a <> 5) and (a <> 6) do    a:= random(7);  writeln(a);
end.

program task2;
var  Digit, i :integer;  DigitStr :string;
begin
  readln(Digit);  str(Digit,DigitStr);  for i:= length(DigitStr) downto 1 do    write(DigitStr[i]);
end.

program task3;
var  Digit :integer;  NewDigit, DigitStr :string;
begin
  readln(Digit);  str(Digit,DigitStr);  NewDigit:= DigitStr[3] + DigitStr[4] + DigitStr[1] + DigitStr[2];  writeln(NewDigit);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?