В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Reaper655
Reaper655
17.02.2021 23:37 •  Информатика

Написать программу,составить алгоритм вычисления среднего арифметического значения массива из 15 целых чисел. числа вводить с использованием генератора случайных чисел. итоговая оценка

Ответ:
124541Artem11111
124541Artem11111
01.10.2020 22:45
Var
  i,n:integer;
  s:real;
begin
  Randomize;
  writeln('Исходные числа');
  s:=0;
  for i:=1 to 15 do begin
    n:=random(100)-50;
    write(n:4);
    s:=s+n
    end;
  s:=s/15;
  writeln;
  writeln('Среднее арифметическое равно ',s)
end.

Тестовое решение:

Исходные числа
  -5 -41 -36  44  -2   8 -24  10   0  20  -8  15  14  35  44
Среднее арифметическое равно 4.93333333333333
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?