В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу в паскале дано три массива a,b,c состоящее из 10 элементов.присвоить массиву d среднее арифметическое каждого элемента этих трех массивов.

Ответ:
полина2125
полина2125
01.10.2020 22:51
Uses crt;
Var a,b,c,d;array [1..10] of integer;
I:integer;
Begin
Clrscr;
Begin
For i:=1 to 10 do
Begin
a[i]:=random(50)+1;
b[i]:=random(50)+1;
c[i]:=random(50)+1;
d[i]:=(a[i]+b[i]+c[i]) div 3;
end;
Write('A) ');
For i:=1 to 10 do
write(a[i],' ');
Writeln;

write('B) ');
For i:=1 to 10 do
write(b[i],' ');
Writeln;

Write('C) ');
For i:=1 to 10 do
write(c[i],' ');
Writeln;

Writeln('Средние значения ');
Write('D) ');
For i:=1 to 10 do
write(d[i],' ');
Writeln;
Readkey;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?