В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
zangalievaira
zangalievaira
23.08.2022 08:57 •  Информатика

Необходимо написать программу на паскале. условие : составить программу формирования двумерного массива из предложенного одномерного так, чтобы первая строка нового массива содержала четные по номеру элементы исходящего массива, а вторая - нечетные. предусмотреть случай нечетного количества элементов массива. например, если мы вводим такой одномерный массив 2 5 1 6 9 2, то должно вывести так: 5 6 2 2 1 9 а если количество элементов одномерного массива нечетное, например 2 5 1 6 9 2 4 то так: 5 6 2 0 2 1 9 4 , заранее !

Ответ:
rotsib
rotsib
07.07.2020 23:58
Var
  a:array[1..50] of integer;
  b:array[1..2,1..25] of integer;
  i,j,n:integer;
begin
  writeln('Вводите элементы массива, конец ввода по значению 7777');
  n:=0;
  repeat
    read(i);
    if i<>7777 then begin
      n:=n+1;
      a[n]:=i
      end
    until i=7777;
  if n mod 2<>0 then begin
    n:=n+1;
    a[n]:=0
    end;
  for j:=1 to n div 2 do begin
    b[2,j]:=a[2*j-1];
    b[1,j]:=a[2*j]
    end;
  writeln;
  for i:=1 to 2 do begin
    for j:=1 to n div 2 do write(b[i,j]:5);
    writeln
    end
end. 

Тестовый прогон:

Вводите элементы массива, конец ввода по значению 7777
2 5 1 6 9 2 7777

    5    6    2
    2    1    9

Вводите элементы массива, конец ввода по значению 7777
2 5 1 6 9 2 4 7777

    5    6    2    0
    2    1    9    4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?