В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Анoнuм
Анoнuм
18.08.2021 21:13 •  Информатика

Паскаль составить программу найти сумму ряда с точностью =10-3 , общий член которого an = ((3^n)*n! )/ (2n)!

Ответ:
evgenscorp1
evgenscorp1
07.07.2020 23:46
Паскаль АВС

Program LoctarUgar;
uses crt;
const
  eps=0.001;

function fact(n : integer) : longint;
  begin
    if n <= 1
         then  fact := 1
         else   fact := n * fact(n - 1);
  end;

var
  t,s:real;
  i:integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Программа вычисляет частичную сумму ряда с заданной точностью');
  writeln('  Общий член ряда:  an = ((3^n)*n! )/ (2n)!');
  writeln('Вычисление прекратится, когда модуль очередного слагаемого станет меньше 0,001');
  writeln();
  s:=0;   i:=1;   t:=1;
  while t>eps do
    begin
      t:=(power(3,i)*fact(i))/(2*fact(2*i));
      s:=s+t;
      writeln('a(',i,')=',t:0:6,'  S=',s:0:6);
      i:=i+1;
     end;
  writeln();
  writeln('Сумма ряда равна',s:0:6);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?