В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
asd135
asd135
28.07.2020 02:30 •  Информатика

Составить программу на ''pascal abc'') дана строка, содержащая текст на языке, и некоторая буква. подсчитать, сколько слов начинается с указанной буквы.

Ответ:
savvakuratov2005
savvakuratov2005
07.07.2020 23:24
var
  str : string;
  i, j: byte;
  schr: char;

begin
  readln(str); //Вводим строку
  str := ' ' + str;  //Это чтобы не удлинять условие, что ниже
  readln(schr); //Вводим символ
  for i := 2 to length(str) do
    if ((upcase(str[i]) = upcase(schr)) and (str[i - 1] = ' ')) then
      inc(j);
  writeln(j);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?