В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
12345671251
12345671251
16.08.2020 19:51 •  Информатика

Составить программу.определить, пересекаются ли линии y=b* x^{2}+c*x+d и y=k*x+m.если пересекаются, найти точки пересечения.

Ответ:
хотам3
хотам3
07.07.2020 22:42
var
  a, b, c, d, k, m: real;

begin
  readln(b, c, d, k, m);
  a := b;
  b := c - k;
  c := d - m;
  d := sqr(b) - 4 * a * c;
  if (a < 0) then
    writeln('Нет точек')
  else
    if (d = 0) then
      writeln('(', (-1 * b + sqrt(d)) / (2 * a), '; ', k * ((-1 * b + sqrt(d)) / (2 * a)) + m, ')')
    else
      writeln('(', (-1 * b + sqrt(d)) / (2 * a), '; ', k * ((-1 * b + sqrt(d)) / (2 * a)) + m, '), (', (-1 * b - sqrt(d)) / (2 * a), '; ', k * ((-1 * b - sqrt(d)) / (2 * a)) + m, ')');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?