Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
bulyginaap08na1
13.06.2022 03:54 •
Информатика
Написать программу в паскали.дан одномерный массив a[n]. найти произведение четных чисел и сумму нечетных.
Ответ:
Аропахора
07.07.2020 22:29
Const
n = 5;
var
a: array [1..n] of byte;
s, k: longint;
b: byte;
begin
k := 1;
for b := 1 to n do
begin
a[b] := random(1, 11);
write(a[b]:3);
end;
writeln();
for b := 1 to n do
if (a[b] mod 2 = 1) then
s := s + a[b]
else
k := k * a[b];
for b := 1 to n do
writeln(s, ' ', k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Irakrasnova72
02.11.2022 07:27
Что такое материнская плата, жёсткий диск, видеокарта ? в чём их значимость? я прост в информатике не...
katmik04
02.11.2022 07:27
Изображение, которое формируется из объектов по указанным формулам...
idalia444
02.11.2022 07:27
Вчём отличие сетевого диска от папки с общим доступом...
Pazitifon3000
13.12.2021 13:22
Что не относится к утилитам: 1) драйвер 2) антивирусные программы 3) программные архитивирование 4) презентацию...
harchuk181002
23.06.2021 21:18
Кто разработчик bitdefender подскажите...
kjkszpjkangaroo
10.05.2023 18:32
Напишите функцию которая находит максимальный элемент переданного ей динамического массива (паскаль)...
Вапрос86
22.11.2021 02:54
Закодируйте в двоичной форме свою фамилию, записанную латинскими буквами(моя фомилия рочива зарание 20 б....
irinacheprasova
11.04.2021 14:16
1. написать программу, которая вычисляет среднее арифметическое ненулевых элементов массива а[1..50], элементы которого вычисляются по формуле: а[i]=sin(i)*cos(i) 2. написать...
Дамирка2288
29.12.2021 01:04
Решить логическое уравнение 1. (b or c and f and c and b) or not f 2. a and b or not (a and not b)...
Nikitymba
14.11.2020 07:55
Загадки к словам : телефон ,стол,диск,записная книжка,мышь и буду...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n = 5;
var
a: array [1..n] of byte;
s, k: longint;
b: byte;
begin
k := 1;
for b := 1 to n do
begin
a[b] := random(1, 11);
write(a[b]:3);
end;
writeln();
for b := 1 to n do
if (a[b] mod 2 = 1) then
s := s + a[b]
else
k := k * a[b];
for b := 1 to n do
writeln(s, ' ', k);
end.