В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Saca2000
Saca2000
05.04.2021 21:54 •  Информатика

Написать программу паскаль, которая формирует массив, элементами которого являются цифры заданного натурального числа.

Ответ:
qwertyqwerty1233
qwertyqwerty1233
07.07.2020 21:49
var
  a: array of byte; //char?
  b, d: integer;

begin
  readln(b);
  SetLength(a, length(IntToStr(b)));
  
  for d := 0 to length(a) - 1 do
  begin
    a[d] := b mod 10;
    b := b div 10;
  end;
  
  for d := 0 to (length(a) - 1) do
    write(a[d], ' ');
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?