В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mkazancev228
mkazancev228
01.02.2021 14:59 •  Информатика

Написать программу для ввода 10 чисел с клавиатуры,не превышающих 1000 и кратных 5. найти сумму этих чисел.

Ответ:
olgagolova2007
olgagolova2007
01.10.2020 22:39
Var
  i,x,s:integer;
  f:boolean;
begin
for i:=1 to 10 do
  begin
  f:=false;
  repeat
    writeln('Введите число:');
    readln(x);
    if (x<=1000) and (x mod 5=0) then
      begin
      s:=s+x;
      f:=true;
      end
      else writeln('Число не удовлетворяет требованиям.');
  until f;
  end;
writeln('Сумма равна : ',s);
end.
0,0(0 оценок)
Ответ:
Дианп11
Дианп11
01.10.2020 22:39
Var a,b: integer;var M: array[1..10] of integer;begina:=1;while a<>1000 do beginreadln(a);b:=b+1;if a mod 10 = 5 then M[b]:=a;end;writeln(M[1]+M[2]+M[3]+M[4]+M[5]+M[6]+M[7]+M[8]+M[9]+M[10]);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?