В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
apologise
apologise
09.06.2020 08:20 •  Информатика

Написать программу на паскале которая определяет, каков процент пробелов во введенном тексте.

Ответ:
Милааа11
Милааа11
07.07.2020 19:05
Var
  s: string;
  i, n, k: integer;

begin
  writeln('Введите текст');
  readln(s);
  n := Length(s);
  k := 0;
  for i := 1 to n do
    if s[i] = ' ' then k := k + 1;
  writeln('Количество пробелов в тексте- ', k)
end.

Тестовый пример:

Введите текст
А роза упала на лапу Азора, а тут ДВА пробела  , а тут вообще пять:     : Все!
Количество пробелов в тексте- 21
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?