В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
лика03481
лика03481
07.01.2022 03:34 •  Информатика

На паскале написать программу которая в последовательность чисел( натуральных), определяет сумму всех чисел кратных 4 и оканчивающихся на 6. программа получает на вход нат числа, признаком окончания ввода явл число 0. могу решить и сам, только нельзя на компе проверить. так что надеюсь на вас.

Ответ:
16Milochka16
16Milochka16
07.07.2020 18:20
Var
  a: integer;
  s: longint;

begin
  s := 0;
  a := -32768;
  while a <> 0 do
  begin
    readln(a);
    if a <> 0 then
      if a mod 4 = 0 then
        if a mod 10 = 6 then s := s + a
  end;
  writeln('Сумма равна ', s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?