В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
juter
juter
10.07.2020 08:49 •  Информатика

Написать программу по паскалю,. известно, что коды прописных (заглавных) букв латинского алфавита следуют в таблице непрерывно друг за другом. коды строчных букв латиницы также следуют непрерывно друг за другом на расстоянии 32 символов от прописных (ниже по таблице) . если ord('a') = 65, то ord('a')+32 = 97, и это код строчной буквы «а» , то есть chr(ord('a')+32) = 'а'. напишите программу, в которой вы вводите прописную букву (только латиницу! ) , а получаете ее строчной эквивалент, и наоборот, по строчной букве получаете соответствующую прописную.

Ответ:
milka0121
milka0121
07.07.2020 15:17
Var c:char;
begin
readln(c);
if ord(c)<97 then
   c:=chr(ord(c)+32)
   else c:=chr(ord(c)-32);
writeln(c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?