В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Дан массив из n целых чисел. найти номер первого элемента, который равен количеству элементов, кратных 3. составить программу алгоритма поиска в паскале

Ответ:
ЯнаШемен
ЯнаШемен
01.10.2020 22:01
Var
  n,i,x:integer;
  a:array[1..20]of integer;
begin
write('Массив: ');
for i:=1 to 20 do
  begin
  a[i]:=random(1,9);
  write(a[i],' ');
  if a[i] mod 3=0 then n:=n+1;
  end;
writeln;
for i:=20 downto 1 do
  if a[i]=n then x:=i;
writeln('ответ: ',x)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?