В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
whitezizickela
whitezizickela
20.05.2022 21:16 •  Информатика

Составить программу вычисления значений функции f(x) на отрезке [а; b] с шагом h. результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции: f(x)=1/2 sin x/4+1

Ответ:
aptemacko
aptemacko
07.07.2020 14:16
Program Table;
uses math; //подключаем математический модуль, возможно с модулем я ошибся
var  // объявляем локальные переменные для программы
    a , b, h : Real; //указывает дробный тип числа

function calculate_f( x: Real) : Real; //объявляем функцию в теле программы
begin
    calculate_f := 1/2*sin(x/4+1) ;   //записываем результат вычисления в функцию
end;

Begin
    a := -0.99; //определяем
    b :=  50.0;  //вводные
    h := 0.1; //значения

    while a < b do begin //пока "a" меньше "b"
        writeln("F(", a, ') = ', calculate_f(a)); //выводим результат вычислений в строку
        a := a + h; //прибавляем шаг "h"
    end;
end.

Я могу и ошибиться, потому что писал на Паскале оочень давно :D
Поэтому Вам прийдется поправить некоторые ошибки в коде.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?