В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
syromyatnikovа
syromyatnikovа
08.08.2021 18:13 •  Информатика

Написать программу для паскаль найдите самую низкую температуру за время наблюдения, если температура опускалась нижу 15 градусов, выведите да, иначе - нет. программа получает на входе количество дней, а для каждого дня вводится температура.

Ответ:
daniladremov
daniladremov
07.07.2020 13:53
Var
  m, k: single;
  i, t: byte;

begin
  m := Single.MaxValue;
  readln(t);
  writeln();
  for i := 1 to t do
  begin
    readln(k);
    m := min(k, m);
  end;
  writeln('Min: ', m, '; ', (m < -15 ? 'Да' : 'Нет'));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?