В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Кристи1801
Кристи1801
26.04.2022 11:42 •  Информатика

Напишите программу в pascal abc в которой нужно определить номера строк двухмерного массива 5х3, содержащего только положительные элементы

Ответ:
tema10112009
tema10112009
07.07.2020 11:50
Const n=5
var
a:array [1..n,1..n] of integer;
d:array [1..n] of integer;
i,j:integer;
begin
for i:=1 to 5 do
for j:=1 to 3 do
readln(a[i,j]);
for i:=1 to 5 do begin
for j:=1 to 3 do begin
if a[i,j]>0 then
d[i]:=d[i]+1;
end;
if d[i]=3 then
d[i]:=i
else
d[i]:=0;
end;
for i:=1 to 5 do
if d[i]>0 then
writeln(d[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?