В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Liphan
Liphan
22.11.2021 19:58 •  Информатика

Составить программу согласно следующему условию. дан одномерный массив а из n элементов.осуществить операцию циклического сдвига на 1 элемент вправо. и блок схему бы еще

Ответ:
kuvandykov05
kuvandykov05
01.10.2020 21:26
На C++

#include <iostream.h>
 const n=10;
  void main()
{ int b,A[n]={1,2,3,4,5,6,7,8,9,0};
   b=A[n-1];
    for(int i=n-2;i>=0;i--) A[i+1]=A[i];
    A[0]=b; for(i=0; i<n;i++)
    cout<< A[i]<<','; }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?