В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
uzinalizs
uzinalizs
22.02.2020 09:10 •  Информатика

Составить программу для нахождения наибольшего общего делителя четырёх натуральных чисел используя процедуру

Ответ:
Амон11111
Амон11111
01.10.2020 21:22
Program z1;
var a,b,c,d:integer;
procedure nod(x,y:integer;var nod2:integer);
begin
        while x<>y do begin
                if x>y then begin
                        x:=x-y
                end
                else begin
                        y:=y-x
                end
        end;
        nod2:=xend;
begin
        write('a=');readln(a);
        write('b=');readln(b);
        write('c=');readln(c);
        write('d=');readln(d);
        nod(a,b,b);
        nod(b,c,c);
        nod(c,d,d);
        writeln('nod=',d);
        readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?