В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bzhx
bzhx
07.12.2021 20:27 •  Информатика

Генератором случайных чисел (от 0 до 100) задан массив из 20 целых чисел.составьте программу, с которой напечатайте на одной строчке исходный массив, а на следующей строке - сумму квадратов элементов с начетными индексами.

Ответ:
povshedna
povshedna
07.07.2020 08:27


тебе как надо решать есть


0,0(0 оценок)
Ответ:
Бигль02
Бигль02
07.07.2020 08:27
Const  n = 20;
var  a :array [1..n] of integer;  i, sum :integer;
begin
  randomize;  for i:= 1 to n do    a[i]:= random(100);  for i:= 1 to n do    write(a[i],' ');  writeln;      sum:= 0;  for i:= 1 to n do    if i mod 2 = 1 then      sum:= sum + sqr(a[i]);  writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?