В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
тёмая
тёмая
18.08.2021 18:56 •  Информатика

С1. составить алгоритм и написать программу на вычисление скорости или пути, при условии, если t> 1часа, тогда вычисляем скорость, иначе путь. каждую строку программы, прокомментировать. входные данные t=2 часа

Ответ:
89087039906qazx
89087039906qazx
07.07.2020 07:54
Алгоритм:
Начало
Ввод t
Если t>1 часа, то
начать выполнение операторов
ввод S;
V=S/t;
вывод V
закончить выполнение операторов
иначе
начать выполнение операторов
ввод V;
S=Vt;
вывод S;
закончить выполнение операторов

Var S,V,t:integer;
begin
read(t);
if t>1 then
begin
read(s);
v:=s/t;
writeln('Скорость=',v);
end
else
begin
read(v);
s:=v*t;
writeln('Расстояние=',s);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?