В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Мариам2065
Мариам2065
15.02.2022 05:16 •  Информатика

Нужно написать программу в паскале описать функцию quarter(x, y) целого типа, определяющую номер координатной четверти, в которой находится точка с ненулевыми вещественными координатами (x, y). с этой функции найти номера координатных четвертей для трех точек с данными ненулевыми координатами.

Ответ:
fdgtrg4gewf
fdgtrg4gewf
07.07.2020 07:39
Var
   i: integer;
   x,y:real;

function Quarter(x,y:real):integer;
begin
if (x>0) and (y>0) then result:=1;
if (x<0) and (y>0) then result:=2;
if (x<0) and (y<0) then result:=3;
if (x>0) and (y<0) then result:=4;
end;

begin
writeln('Введите координаты точки');
readln(x,y);
i:=Quarter(x,y);
writeln('Номер координатной четверти; ',i)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?