В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ros25
ros25
29.01.2021 22:25 •  Информатика

Написать программу на паскаль: найти произведение наибольших элементов двумерного массива, первый элемент которого отрицателен.

Ответ:
натали200652
натали200652
07.07.2020 07:10
Если имеется в виду произведение наибольших в каждой строке элементов, то тогда так:
var
   i,j,p:integer;
   max:array[1..5]of integer;
   a:array[1..5,1..5]of integer;
begin
p:=1;
for i:=1 to 5 do
  for j:=1 to 5 do
    a[i,j]:=random(-10,10);
a[1,1]:=random(-10,-1);
for i:=1 to 5 do
  begin
  for j:=1 to 5 do
    begin
    write(a[i,j]:4);
    if a[i,j]>max[i] then max[i]:=a[i,j];
    end;
  p:=p*max[i];
  writeln;
  end;
writeln('P=',p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?