В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
NokuShinama
NokuShinama
17.05.2020 13:40 •  Информатика

Написать программу в паскале: даны две строки: s1 и s2. можно ли из символов строки s1 составить строку s2? регистр значения не имеет. (например a) s1=’april’, s2=’may’. ответ: false b) s1=’rom’, s2=’room’. ответ: false, т.к. буква ‘o’ встречается в строке s1 один раз. c) s1=’tomorrow’, s2=’motor’. ответ: true)

Ответ:
danilrykov200
danilrykov200
07.07.2020 06:52
Var
  i,n:integer;
  s1,s2:string;
  f:boolean;
begin
f:=true;
writeln('Введите первую строку');
readln(s1);
writeln('Введите вторую строку');
readln(s2);
s1:=LowerCase(s1);
s2:=LowerCase(s2);
i:=1;
repeat
  n:=pos(s2[i],s1);
  if n>0 then delete(s1,n,1) else f:=false;
  i:=i+1;
  until i=length(s2);
writeln(f)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?