В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
оксана731
оксана731
25.04.2023 16:07 •  Информатика

Написать программу которая классифицирует треугольники равнобедренный, равносторонний,прямоугольный,если даны 3 стороны треугольника.

Ответ:
KekalolQ
KekalolQ
07.07.2020 01:39
Var a,b,c:real;
begin
writeln('Введите 1 сторону треугольника');
readln(a);
writeln('Введите 2 сторону треугольника');
readln(b);
writeln('Введите 3 сторону треугольника');
readln(c);
if (a=b)and(b=c) then writeln('Равносторонний треугольник')
else if (a=b) or(b=c)or(a=c) then writeln('Равнобедренный треугольник')
else if (sqr(a)=sqr(b)+sqr(c))or(sqr(b)=sqr(a)+sqr(c))or(sqr(c)=sqr(b)+sqr(a)) then writeln('Прямоугольный треугольник')
else writeln('Обычный треугольник');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?