В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vlad1446
vlad1446
18.09.2021 06:20 •  Информатика

Напишите программу формирования и вывода массива размером 6*3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-й равен 500 2-й равен целой части квадратного корня из предыдущего элемента 3-й равен целой части от деления суммы индексов текущего элемента на 3 ( если она равна 0, то соответствующий элемент массива делать равным 1). в pascal

Ответ:
24556
24556
07.07.2020 01:22
Как-то так)

const n=6; m=3;
var a:array[1..n,1..m] of integer;
i,j:integer;
begin
for i:=1 to n do
for j:=1 to m do a[i,j]:=random(50);
for i:=1 to n do
for j:=1 to m do begin
if j=1 then a[i,j]:=500;
if j=2 then a[i,j]:=trunc(sqrt(a[i,j-1]));
if j=3 then a[i,j]:=(i+j) div 3;
end;
for i:=1 to n do begin
for j:=1 to m do write(a[i,j]:5);
writeln;
end;
end.
0,0(0 оценок)
Ответ:
vapapsroyflmq
vapapsroyflmq
07.07.2020 01:22
Var a:array[1..3,1..6] of integer;x,y:integer;
begin
for y:=1 to 6 do begin
for x:=1 to 3 do begin
if x=1 then a[x,y]:=500;
if x=2 then a[x,y]:=trunc(sqrt(a[x-1,y]));
if x=3 then a[x,y]:=trunc((x+y)3);
if x<>3 then write(a[x,y],' ');
end;
writeln(a[x,y]);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?