Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Maria20511
09.09.2022 08:37 •
Информатика
Написать программы в паскале • дан массив из n вещественных чисел. поменять местами последний и минимальный элементы массива. • дан массив из n целых чисел. найти номер первого элемента, который равен количеству элементов, кратных 3.
Ответ:
ramazancheh20
06.07.2020 23:06
Program task1;
const
n = 10;
var
a :array [1..n] of real;
i, j :integer;
min, k :real;
begin
for i:= 1 to n do
readln(a[i]);
min:= a[1];
for i:= 1 to n do
if a[i] < min then
begin
min:= a[i];
j:= i;
end;
k:= a[n];
a[n]:= a[j];
a[j]:= k;
end.
program task2;
const
n = 10;
var
a :array [1..n] of integer;
i, j, kol :integer;
begin
for i:= 1 to n do
readln(a[i]);
kol:= 0;
for i:= 1 to n do
if a[i] mod 3 = 0 then
inc(kol);
for i:= 1 to n do
if a[i] = kol then
begin
j:= i;
break;
end;
writeln(j);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
merlinina74
27.08.2020 17:50
какие значения будет принимать величина- счетчик при выполнении следующего цикла: от x=-100 до 10 шаг в кумире...
DeadShotDS
05.02.2020 15:47
Определите функцию,которая используется в ячейке B2. Атрибутом функции является ссылка A2 ЦЕЛОЕ()ОТБР()КОРЕНЬ()СТЕПЕНЬ()...
korostin2004
24.11.2022 19:04
Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. к примеру было 123456 должно стать 1 2 3 4 5 5 программа должна быть написана на языке паскаль....
ayaulym10
09.04.2021 14:17
Сделать сайт,9 класс на тему дворцы ораненбаума...
petechkaPetrovPetor
09.04.2021 14:17
Из каких блоков состоит звуковая карта компьютера ?...
Happymilks
15.08.2022 20:43
Сколько кбайтов содержится в 57344 битах...
a06b07c2005
31.01.2021 14:09
Какое количество информации требуется для двоичного кодирования каждого символа набора из 256 символов...
25424446645
10.01.2020 07:05
Файл с моно звуком имеет глубину кодирования 16 битов и частоту дискретизации 16 000. вычислите информационный объём файла в килобайтах, если продолжительность его звучания 30с...
vikimeis2006
10.08.2022 15:02
Какая система счисления используется для кодирования числовой информации в компьютере...
baget97ozu06u
06.05.2022 18:06
1.скорость передачи данных через adsl соединение равна 512000 бит/с. через данное соединение файл размером 935 кбайт. определите время передачи в секундах. 2. сообщение, информационного...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const
n = 10;
var
a :array [1..n] of real;
i, j :integer;
min, k :real;
begin
for i:= 1 to n do
readln(a[i]);
min:= a[1];
for i:= 1 to n do
if a[i] < min then
begin
min:= a[i];
j:= i;
end;
k:= a[n];
a[n]:= a[j];
a[j]:= k;
end.
program task2;
const
n = 10;
var
a :array [1..n] of integer;
i, j, kol :integer;
begin
for i:= 1 to n do
readln(a[i]);
kol:= 0;
for i:= 1 to n do
if a[i] mod 3 = 0 then
inc(kol);
for i:= 1 to n do
if a[i] = kol then
begin
j:= i;
break;
end;
writeln(j);
end.