В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
liteman1000ow7ldr
liteman1000ow7ldr
17.11.2020 02:52 •  Информатика

Составьте программу для pascal abc, решающую следующую . у продавца имеются гири весом 1, 2, 5 кг. наберите минимальное кол-во гирь для взвешивания n кг.

Ответ:
123Dulya
123Dulya
06.07.2020 22:38
Program z1;
        var n:integer;
        s1,s2,s5:integer;
begin
        write('n=');readln(n);
        s5:=n div 5;n:=n mod 5;
        s2:=n div 2;s1:=n mod 2;
        writeln('5 kg-',s5,';   2 kg-',s2,';   1 kg-',s1);
        readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?