В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Maryyy100
Maryyy100
28.10.2021 10:57 •  Информатика

Составить программу , в среде pascal abc (turbo pascal) выполняющую вычисления по формуле: y=2ctg3x- распешите все действия что писать .

Ответ:
lissden7
lissden7
01.10.2020 20:43
Паскаль АВС:

Program Ikiru;
uses crt;
var
  y,x:real;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
    write('Введите Х '); readln(x);
    if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)<=0)
      then
        writeln('Функция Y для этого значения Х не определена')
      else
        begin
          y:=2*(cos(3*x)/sin(3*x))-ln(cos(x))/ln(1+x*x);
          writeln('y=',y:8:2);
        end;
end.

Пояснения:
write('Введите Х '); readln(x);
  - программа просит пользователя ввести х
if (sin(3*x)=0) or (ln(1+x*x)=0) or (cos(x)<=0)
  - проверка существования функции (функция ctgХ не существует, если sinX=0, ln берется только от неотрицательных значений, в знаменателе дроби не может быть 0)
Если хотя бы одно из условий не выполняется,  выводится ссобщение о том, что функция для этого значения не определена.
Если все проверки пройдены, программа вычисляет значение функции Y и выводит его на экран.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?