В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nagimako
nagimako
04.02.2020 20:13 •  Информатика

Нужно составить в программе с++ 1) найти сумму всех натуральных чисел от 10 до 30 ,выводя на экран все промежуточные результаты и используя все три вида циклов 2) написать программу,которая считает, сколько раз в последовательности из 10 чисел встречаются введенное с клавиатуры число а, используя все три вида циклов 3)вычислить значение функции y=a^2+|b|+5a-10b 4) дано целое число .если оно является положительными, то прибавить к нему 1; в противном случае вычисляя из него 2.вывести на печать получившийся число 5)вычислить значение функции u=x+1 на отрезке от 0 до 10 с шагом 0.3

Ответ:
adamswpp
adamswpp
06.07.2020 17:18
Задача №1.
#include<iostream>
#include<math.h>
using namespace std;
long i,sum;
int main()
{
for(i=10; i<=30; i++)
{
sum+=i;
cout<<sum<<endl;
}
return 0;
 }
#include<iostream>
#include<math.h>
using namespace std;
long i,sum;
int main()
{
 i=10;
sum=0;
while(i<=30)
{
sum+=i;
cout<<sum<<endl;
i++;
}
 return 0;
}
#include<iostream>
#include<math.h>
using namespace std;
long i,sum;
int main()
{
 i=10;
sum=0;
do
{
sum+=i;
cout<<sum<<endl;
i++;
}
while(i<=30);
return 0;
}
№2
#include<iostream>
#include<math.h>
using namespace std;
long i,a,b,k;
int main()
{
 cin>>a;
for(i=1; i<=10; i++)
{
cin>>b;
if(b==a) k++;
}
cout<<k;
 return 0;
}
#include<iostream>
#include<math.h>
using namespace std;
long i,a,b,k;
int main()
{
i=1;
cin>>a;
while(i<=10)
{
cin>>b;
if(b==a) k++;
i++;
}
cout<<k;
return 0;
}
#include<iostream>
#include<math.h>
using namespace std;
long i,a,b,k;
int main()
{
i=1;
cin>>a;
do
{
cin>>b;
if(b==a) k++;
i++;
}
while(i<=10);
cout<<k;
return 0;
}
№3
#include<iostream>
#include<math.h>
using namespace std;
long a,b,k;
int main()
{
cin>>a>>b;
k=a*a+abs(b)+5*a-10*b;
cout<<k;
return 0;
}
№4
#include<iostream>
#include<math.h>
using namespace std;
long a,b,k;
int main()
{
cin>>a;
if(a>=0) a++;
else a-=2;
return 0;
}
№5
#include<iostream>
#include<math.h>
using namespace std;
double i,u;
int main()
{
for(i=0; i<=10; i+=0.3)
{
u=i+1;
cout<<u<<endl;
}
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?