В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
GelyaKazarik
GelyaKazarik
02.06.2021 08:47 •  Информатика

Написать программу на языке pascal: : вводятся целые числа до первого числа, которое меньше двух. определить, сколько простых чисел было введено. описание переменных: q - счетчик простых чисел; n - очередное введенное число. алгоритм решения : пока введенное число больше 1, проверять его на простоту по следующему алгоритму: если число делится на любой делитель от 2 до половины от себя, то оно не простое. если число так и не разделилось ни на один из перебранных делителей, то оно простое, следовательно, увеличиваем счетчик простых чисел.

Ответ:
Kuznecovaalexa2005
Kuznecovaalexa2005
06.07.2020 16:00
Var q,n,i,k,h:integer;
begin
readln(n);
h:=1;
while n>1 do
  begin
  k:=n div 2;
  for i:=2 to k do
    if n mod i=0 then h:=0;
  q:=q+h;
  h:=1;
  readln(n);
  end;
writeln('Простых чисел: ',q)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?