В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
margarinchik2008
margarinchik2008
15.05.2021 22:29 •  Информатика

Напишите программу в паскале на нахождение суммы главных диагоналей для квадратной матрицы. ,

Ответ:
dmitriyslesarev
dmitriyslesarev
01.10.2020 20:31
Program matrica;
Uses crt;
Var a:array [0..8 ,  0..8] of integer;
       sum1,sum2,i,j:integer;
begin
randomize;
sum1:=0;
sum2:=0
for i:=1 to 8 do
begin
Writeln;
for j:=1 to 8 do
begin
a[i,,j]:=random(10);
if i=j then sum1:=sum1+a[i,j];
if i+j=9 then sum2:=sum2+a[i,j];
Write(a[i,j], '    ');
end;
end;
writeln('Сумма чисел первой диагонали -',sum1,'  'Сумма чисел второй диагонали' ,sum2,');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?