В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anakina1
Anakina1
10.03.2022 00:24 •  Информатика

Как написать программу, которая в последовательности чисел (количество вводится с клавиатуры) определяет сумму чисел, кратных 9 и оканчивающихся на 3. pascalabc.net

Ответ:
Aliska17
Aliska17
01.10.2020 20:18
Var
a: array of integer;
i,n, s: integer;
begin
write('Введите количество чисел: ');
readln(n);
SetLength(a, n);
s:=0;
for i:=0 to n-1 do 
begin 
write('Введите число', i+1, ': '); 
readln(a[i]); 
if (a[i] mod 9 = 0) and (a[i] mod 10 = 3) then s:=s+a[i]; 
end;
writeln;
writeln('Исходный массив:');
for i:=0 to n-1 do write(a[i]:5);
writeln;
writeln('Сумма чисел, кратных 9 и оканчивающихся на 3 = ', s:5);
a:=nil;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?