В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Мини196
Мини196
10.11.2021 04:38 •  Информатика

Написать программу (в паскале) , которая вводит с клавиатуры 5 дробных чисел и вычисляет их среднее арифметическое.рекомендуемый вид экрана во время работы программы ниже. данные, введенные пользователем выделены полужирным шрифтом.вычисление среднего арифметического последовательности дробных чисел. после ввода каждого числа нажимайте . -> 5.4 -> 7.8 -> 3.0 -> 1.5 -> 2.3 среднее арифмитическое введенной последовательности: 4. 00 для завершения работы программы нажмите < enter> .

Ответ:
лох252
лох252
25.05.2020 05:17

var i: integer;

var a  : array[1..5] of real;

begin

for i in [1..5] do

    begin

    write('->');

    readln(a[i]);

end;

writeln((a[1]+a[2]+a[3]+a[4]+a[5])/5:0:2);

end.

0,0(0 оценок)
Ответ:
alyafalendysh
alyafalendysh
25.05.2020 05:17

program dgh;

var

a,b: real;

i: integer;

Begin

b:=0;

for i:=1 to 5 do

begin

Write ('->'); readln (a);

b:=b+a;

end;

write('среднее арифметическое введенной последовательности:');

write (b/5:0:2);

Readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?