Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
GloSef
31.10.2021 20:57 •
Информатика
Дан массив a(4). найти максимальный элемент массива и его порядковый номер. на паскале.
Ответ:
viktoriaedel
06.07.2020 11:57
Const n=4;
var A:array [1..n] of real;
i,max,j:integer;
maxs:real;
begin
for i:= 1 to n do
readln(A[i]);
for i:= 1 to n do
for j:= 1 to n do
if A[i]>A[j] then
begin
maxs:=A[i];
max:=i;
end;
writeln(maxs,' ',max)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
caros14
24.03.2021 09:15
2. программа получает 3 три случайные числа от 0 до 9. вывести на экран эти числа и их среднее арифметическое. 3. пользователь вводит число n. вывести на экран через...
Кристина1081567
16.04.2020 17:31
Винни-пух начал готовиться к зиме и запасаться мёдом. в первый день он принёс в погреб один горшок мёда, а в следующие дни он приносил в два раза больше горшочков мёда,...
natilis
09.05.2020 03:54
Преимуществами языка Python являются Варианты ответов платформонезависимость встраиваемость простота наличие большой библиотеки классов динамическая типизация (для несложных...
elensarkisian
14.09.2022 09:08
написать программу на C# В массиве хранится информация о стоимости 1 килограмма 30 видов конфет. Определить порядковый номер самого дешевого вида конфет. Если таких видов...
kosenkoanton72
31.08.2020 08:20
1. Как строится ряд натуральных чисел в разных позициях систем счисления (от 1 до 10) 2.Какое минимальное основание должна иметь система счисления, если в ней можно записать...
aaaaa123456789p
01.10.2022 01:43
решить ошибку. В тексте ошибки написано: Failed to compile ./node_modules/@vkontakte/vkui/dist/components/ActionSheetItem/ActionSheetItem.js Module not found: Can t resolve...
Sherlokzn
15.07.2020 10:28
Для каких из данных слов истинно высказывание (оказывается на мягкий знак или не ( количество букв чётное) 1 сентябрь 2 август 3 декабрь 4 май 5 март...
marisha0606
20.04.2021 14:11
информационные процессы - это? информационные технологии - это?...
Maci189
30.03.2023 21:53
Паскаль авс. вводится n целых чисел. написать программу подсчета количества чисел, в записи которых содержится цифра 8. при этом требуется написать функцию вида: function...
alina124561
09.09.2020 05:08
Переведите числа в восьмеричную и шестнадцатеричную системы счисления 10101101010...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var A:array [1..n] of real;
i,max,j:integer;
maxs:real;
begin
for i:= 1 to n do
readln(A[i]);
for i:= 1 to n do
for j:= 1 to n do
if A[i]>A[j] then
begin
maxs:=A[i];
max:=i;
end;
writeln(maxs,' ',max)
end.