Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
3344227p06s57
25.02.2020 13:00 •
Информатика
Написать программу, которая определяет, является ли строка палиндромом (на с++)
Ответ:
Roserum
06.07.2020 11:52
#include <conio.h>
#include <iostream>
using namespace std;
int main()
{
char s[255];
bool palindrom=true;
gets(s);
for(int i=0;i<strlen(s)/2;i++)
{
if(s[i]!=s[strlen(s)-i-1])
{
palindrom=false;
break;
}
}
if(palindrom)
cout<<endl<<"Palindrom";
else
cout<<endl<<"Ne palindrom";
getch();
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Бла161
25.05.2023 00:45
Рассчитайте время представления фильма, занимающего объем памяти 660 Мбайт, на экране монитора в разрешением 800*600 пикселей и палитрой из 256 цветов, если за 1с сменяется...
Люсик20
07.10.2021 17:07
Решить по паскалиabc 30 гипотенуза прямоугольного треугольника равна с, а один из катетов а. найти площадь этого треугольник....
adsdfghjohgfds
28.08.2020 00:11
Корневым каталогом называется… каталог верхнего уровня каталог среднего уровня каталог нижнего уровня каталог самого верхнего уровня...
Dana1906
13.12.2020 21:52
Решить премер столбиком по действием (32-132,3: 12,6)*6,4+262,4...
khgssfghdwwcnoy
13.12.2020 21:52
Относятся к вегетативной нервной системе...
Mia871
13.12.2020 21:52
Какие с/х культуры выращиваются в казахстане...
kacok2
13.12.2020 21:52
Рынок регулирует отношения в свери 1)производста 2)потребления 3) распределение 4) обмена...
vehea78347
13.12.2020 21:52
Кто из перечисленных российских ученых конца xix – начала хх вв. внес вклад в развитие естественных наук?...
данил2060
13.12.2020 21:52
Из сказки финист ясный сокол волшебные предметы...
DanilSv040
13.12.2020 21:52
Вкаком году были установленны памятники сирену и...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
using namespace std;
int main()
{
char s[255];
bool palindrom=true;
gets(s);
for(int i=0;i<strlen(s)/2;i++)
{
if(s[i]!=s[strlen(s)-i-1])
{
palindrom=false;
break;
}
}
if(palindrom)
cout<<endl<<"Palindrom";
else
cout<<endl<<"Ne palindrom";
getch();
return 0;
}