В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Flexx1337
Flexx1337
28.03.2020 20:05 •  Информатика

Св "паскале"! 1. составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа n. проверьте алгоритм трассировкой.(объясните за одно, что такое "трассировка") 2. дано целое число х и натуральное n. составьте алгоритм вычисления х^n. проверьте алгоритм трассировкой.

Ответ:
lavin997
lavin997
06.07.2020 11:37
1)
var
    i, n, m: integer;

begin
    readln(n);
    for i := 1 to n do
        m := m + i;
    writeln('сумма всех натуральных чисел не превышающих ', n, ' - ', m);
end.

2)
var
    x, n, i, p: integer;

begin
    write('Число: ');
    readln(x);
    write('Степень :> ');
    readln(n);
    p := 1;
    for i := 1 to n do
        p := p * x;
    writeln('Результат: > ', p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?