В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pinkiepieanddash
pinkiepieanddash
13.06.2022 10:16 •  Информатика

Напишите программу,которая находит и выводит все трехзначные числа,средняя цифра которых равна сумме первой и второй цифр ​

Ответ:
hvbdnnd
hvbdnnd
07.06.2020 00:51

Стандартный алгоритм на плюсах:

НО  мне кажется что в задании есть опечатка и нужно найти числа, где средняя равна сумме первой и третьей.

Навсякий приведу и тот и тот вариант

1) Вариант(КАК В ЗАДАНИИ)

#include <iostream>

using std::cin,std::cout,std::endl;

int main(){

       for (size_t a=0; a<=9;++a){

               for (size_t b =0;b<=9;++b){

                       for (size_t c = 0; c<=9;++c){

                               if (b == a+b)

                                       cout << a << b<<c << endl;

                       }

               }

       }

return 0;

}

2) Вариант2 (как я думаю)

#include <iostream>

using std::cin,std::cout,std::endl;

int main(){

       for (size_t a=0; a<=9;++a){

               for (size_t b =0;b<=9;++b){

                       for (size_t c = 0; c<=9;++c){

                               if (b == a+c)

                                       cout << a << b<<c << endl;

                       }

               }

       }

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?