В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lili2005ok
lili2005ok
02.06.2022 17:36 •  Информатика

Напишите программу, которая считывает с клавиатуры строку s и определяет, встречаются ли в строке s слова палиндромы. словом считается последовательность символов, ограниченная проьелами, и не имеющая пробелов внутри себя. строка s не пустая, содержит не более 200 символов и состоит только из строчных и прописных букв латинского алфавита и пробелов

Ответ:
Голубоглазый234
Голубоглазый234
01.10.2020 20:09
Var
 s,t:string;
 n,i:integer;
begin
write('Введите строку: ');
readln(t);
n:=1;
t:=t+' ';
for i:=2 to length(t) do
  if ((t[i]=' ') or (i=length(t)))  and (i-n>1) then
    begin
    s:=Copy(t,n,i-n);
    if s=ReverseString(s) then
      begin
      writeln('Да, палиндромы есть');
      halt
      end
        else n:=i+1
    end;
writeln('Палиндромов нет')    
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?