В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alinashakeeva
alinashakeeva
17.03.2023 22:55 •  Информатика

Паскаль напишите программу, которая 10 раз запрашивает ввод целого числа. при завершении ввода на экран выводится сумма чисел, минимальное число, максимальное число.

Ответ:
sanekmmg1980
sanekmmg1980
01.10.2020 20:07
Program Lana132;
uses crt;
const n=10;
var
  i,ch,max,min,sum:integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
  writeln('Программа запрашивает N чисел, находит их сумму, максимальное и минимальное число');
  sum:=0;
  write('Введите 1-e число: '); read(ch);
  sum:=sum+ch;
  max:=ch; min:=ch;
  for i:=2 to n do
    begin
      write('Введите ',i,'-e число: '); read(ch);
      sum:=sum+ch;
      if max<ch then max:=ch;
      if min>ch then min:=ch;
   end;
  writeln('Сумма всех чисел равна ',sum);
  writeln('Максимальное число равно ',max);
  writeln('Минимальное число равно ',min);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?