В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Надо написать программу в паскале вычисления площади круга если известна длина окружности

Ответ:
Drzk
Drzk
01.10.2020 19:42

Формула вычисления длины окружности L=2\pi R, откуда радиус окружности R=\frac L{2\pi}. Подставляем радиус в формулу площади S=\pi R^2 и получаем S=\frac{L^2}{4\pi}

var S, L: real;

begin

 read(L);

 write(L * L / (4 * PI))

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?