В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
аааааааа36
аааааааа36
20.02.2020 11:26 •  Информатика

Составить программу в паскале 1)игровой автомат выдает целые числа от 0 до 10 если выпадает 7, то выйгрыш. 2)игровой автомат получает 3 случайных числа от 0 до 10, если числа совпадут, то выйгрыш 3)вывести на экран 10 случайных чисел от 0 до 100, и определить сколько из них чётных надо к завтрашнему дню, заранее .

Ответ:
Юра22858
Юра22858
05.07.2020 19:46
1)
var
i:integer;
begin
randomize;
i:=random(11);
writeln('vipalo chislo: ',i)
;if (i = 7) then writeln('POBEDA!') else writeln('Pobrobyite eshe!');
end.

2)
var
i_1,i_2,i_3:integer;
begin
randomize;
i_1:=random(11);
i_2:=random(11);
i_3:=random(11);
writeln('vipalo chislа: ',i_1,' ',i_2,' ',i_3);

if (i_1 = i_2)and(i_2 = i_3) then writeln('Winer!') else writeln('Sorry,try again!')
end.
3) var  i, k, z: integer;
begin 
 randomize; 
k := 0; 
for i := 1 to 10 do  
 begin   
 z := random(101); 
  write(' ', z); 
   if odd(z) then k := k + 1; 
 end; 
 writeln; 
 writeln('Kolichestvo chetnysh: ', k);
  end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?